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File Menu

The File menu includes commands that enable you to open and save files, to batch convert
files to JPEG, and to display multiple images in a selected order.

For more information, select the File menu command name.

Open
Save

Save All Options
Batch Conversion
Slideshow

Exit




Edit Menu

The Edit menu includes commands that enable you to transfer images to and from the
clipboard, to change the color components of an image, and to manipulate the image.

For more information, select the Edit menu command name.

Copy

Paste

HSV Adjustment

Color Balance
Contrast Enhancement
Rotate

Flip Horizontal

Flip Vertical
Resize




Options Menu

The Options menu includes commands that let you determine how other commands operate.
The settings for the options can be saved with the Save All Options command.

For more information, select the Options menu command name.

8-Bit Bitmap
Dither24tol5
Auto-resize
Show Scroll Bars
Cycle Slideshow
Low Priority

JPEG Options
Memory Options




File Open command (File Menu)

Select the name of a file to display and the file format which is the JPEG File Interchange
Format(JFIF), GIF(GIF 87a), TARGA, or uncompressed Windows BMP. When you click on one
of the file format buttons, WinJPEG will display a list of all the files in that format in the
current path. Pressing the "Display" button will display an image (with the selected display
options if the image is a JPEG). Pressing the "Preview" button will display a JPEG image with
1-pass quantization and dithering off. This combination will display an image 25-50% faster
than 2-pass quantization with dithering on.

JPEG , TARGA, and 24-bit Windows BMP images are loaded into either an 8-bit or 24-bit
bitmap which is determined by the 8-bit Bitmap option. GIF images and 1, 4, and 8-bit
Windows BMP files are automatically stored in an 8-bit bitmap.



File Save command (File Menu)

Select the name of the output file and the output format, which is the JPEG File Interchange
Format(JFIF), GIF(GIF 87a), TARGA, BMP or OS/2 BMP. When you save an image to TARGA
or one of the BMP formats, the bits per pixel of the output file is the same as the bits per
pixel of the bitmap that is currently displayed. For example, if an 8-bit bitmap is
displayed(the image is stored in an 8-bit bitmap when you are in 256-color mode or you
check the "Use 8-bit bitmap" option), WinJPEG will save the picture to an 8-bit file.
Similarly, if a 24-bit bitmap is displayed, it will save to a 24-bit format.



Save All Options command (File Menu)

This will save all the WinJPEG options to a file named "winjpeg.sav" in the same directory as
the WinJPEG executable. When WinJPEG is initially loaded, the options will be loaded if
"winjpeg.sav" exists.



Batch Conversion command (File Menu)

Select GIF and TARGA files to convert to JPEG format. The list box on the left displays the
files in the current path and the list box on the right displays a list of files to be converted.
To add a file to the latter box, select the files you want to convert and press the "Add"
button. Files without the appropriate extension, ".gif" or ".tga," will not be added.

If you decide to abort the conversion while it is in the process of converting, click on the
window with the left mouse button, click on the "Yes" button in the confirmation dialog, and
the conversion will halt after the current file is completed.

The output file(s) will have the same name as the input file(s) except that they will have a
".jpg" extension. Also, the output file(s) will be placed in the same path as the input file(s).



Slideshow command (File Menu)

Select the GIF, TARGA, and JPEG files to display in a slideshow. The order in which you add
the files will be the order in which they are displayed. After a picture is loaded and
displayed, there will be a user-selected delay before the next picture is loaded.

If you would like the slideshow to go back to the first picture after the last one is displayed
and to display the selected files continuously, check off the Cycle Slideshow menu option.

If you would like to abort the slideshow, click on the window with the left mouse button, click
on the "Yes" button in the confirmation dialog, and the slideshow will stop after the currently
loading picture is displayed.



Exit command (File Menu)

Exit from WinJPEG. While WinJPEG is compressing/decompressing an image, you can exit by
using the Close command in the system menu.



Copy command (Edit Menu)

Copy the entire image into the clipboard. WinJPEG posts the image in Windows bitmap and
Device-Independent Bitmap(DIB) formats.



Paste command (Edit Menu)

Paste an image from the clipboard. The clipboard must contain either a Windows bitmap or
an uncompressed Device-Independent Bitmap(DIB).



HSV Adjustment command (Edit Menu)

Use the scroll bars to adjust the amount of hue, saturation, and value/brightness in an
image. A value of 0 on the scroll bar means that there is no change in the corresponding
color component. When the value is increased or decreased, the color component is
increased or decreased, respectively. Warning: the HSV calculations are very slow in 24-bit
mode.



Color Balance command (Edit Menu)

Use the scroll bars to adjust the amount of red, green, and blue in an image. A value of 0
on the scroll bar means that there is no change in the corresponding color component.
When the value is increased or decreased, the color component is increased or decreased,
respectively.



Contrast Enhancement command (Edit Menu)

Use the scroll bar to adjust the amount of contrast in an image. A value of 0 on the scroll
bar means that there is no change in the contrast. When the value is increased or
decreased, the contrast is increased or decreased, respectively.



Rotate command (Edit Menu)

Rotate the image clockwise by 90 degrees.



Flip Horizontal command (Edit Menu)

Flip the image around the vertical axis.



Flip Vertical command (Edit Menu)

Flip the image around the horizontal axis.



Resize command (Edit Menu)

Change the spatial resolution of the image.



8-bit Bitmap command (Options Menu)

When you load a JPEG, TARGA, or 24-bit Windows BMP image with this menu item checked,
WinJPEG will quantize the number of colors to 256, and display the image in an 8-bit bitmap.
If this menu item is unchecked, a JPEG or TARGA image will be loaded into a 24-bit bitmap
with no quantization. This option affects only viewing JPEG, TARGA, and 24-bit Windows
BMP images.



Auto-resize command (Options Menu)

When this option is checked, WinJPEG will automatically resize the window so that the image
will fit just inside the window. When an image is initially loaded, the window size is changed
so that the largest possible portion of the image is displayed. When you change the window
size so that it is larger than the image size, the window will be resized so that it just fits
around the image. Also, scroll bar(s) are activated if they are needed.



Dither24tol5 command (Options Menu)

This option is available only if you are using a 32k color display mode or better. When it is
checked and the 8-Bit Bitmap option is off, JPEG, TARGA, or 24-bit Windows BMP images will
be dithered to 15-bits per pixel so that they can be displayed properly.



Show Scroll Bars command (Options Menu)

This option is available only if auto-resize is off. It lets you choose whether or not the scroll
bars are activated.



Cycle Slideshow command (Options Menu)

When a slideshow is running, this option determines whether or not a list of images are
continuously displayed in a cycle. If this option is on, the slideshow returns back to the first
picture after the last one is displayed and continues to display all the images in a selected
list until you abort the slideshow by clicking on the window with the left mouse button.



Low Priority command (Options Menu)

When this menu item is checked, WinJPEG will give more CPU time to other programs
running at the same time as WinJPEG. This option works during the
compression/decompression of JPEG images and loading of TARGA images. It will take
slightly longer to compress/decompress with this option on.



JPEG Options command (Options Menu)

1-pass quantization is faster than the 2-pass(Heckbert) option but the output for the former
generally looks more grainy. Also, 2-pass quantization requires more memory so it may be
even slower because WinJPEG will swap to hard disk when it runs out of physical memory.

The dithering method is Floyd-Steinberg; dithering is useful when quantizing to 256 colors
but it is not needed for a true-color (24-bit) display. In some cases, you may want to turn
off dithering since it sometimes causes a grainy output image.

The quality factor, an integer between 0 and 100 inclusive, determines the tradeoff between
the output file size and the output image quality. If you choose a high quality factor, the
image quality will be high but the file size will be large. A lower quality setting will yield a
smaller file at a cost of lower fidelity. Since the JPEG algorithm is lossy, a quality factor of
100 will not give you a losslessly compressed image.

Entropy optimization produces a smaller JPEG file but it takes more time to encode the
image.



Memory Options command (Options Menu)

When WinJPEG needs more memory, it can use virtual memory, selected by the "Available
Memory" button, or it can use temporary files, selected by the "Temporary File" button. If
the former option is selected, and WinJPEG runs out of virtual memory, temporary files will
automatically be used.

Temporary files are created in the directory chosen by the user and they are deleted when
WinJPEG is done with the "memory" or when the user aborts decompression/compression of
an image by closing the program.

In general, the "Available Memory" should be selected when your system has at least 8Mb of
RAM, and the "Temporary File" should be selected when you have little RAM or you are
multitasking memory-intensive programs.



JPEG

Joint Photographic Experts Group (JPEG) refers to a still-picture compression standard that
specifies several modes of operation. The mode used by the Independent JPEG
Group's(lJPEG) software, which is incorporated into WinJPEG, is sequential buildup; in this
mode, each component of an image is encoded in a left-to-right and top-to-bottom scan.
Sequential mode is lossy, which means that when you compress an image, you will lose
information. That is, when you decode the compressed image, the decoded image will not
exactly match the original. One reason that sequential mode JPEG is lossy is that the

algorithm compresses an image by removing visually insignificant information, colors that
the human eye cannot detect.



JPEG File Formats

The JPEG committee has not specified a standard file format, and consequently, many
applications of the JPEG algorithm use their own proprietary format. WinJPEG uses the JPEG
File Interchange Format(JFIF) which transports only pixel information. JFIF is supported by
the IJPEG Group's software and other programs based on their code.

Handmade Software's GIF2JPG and Image Alchemy by default use a proprietary JPEG format
that is not compatible with the JFIF standard. This proprietary format is not supported by
WiInJPEG. When you use GIF2JPG, remember to use the "-j" option to produce a JPEG file
that is compatible with the JFIF standard and viewable with WinJPEG.

For some reason, the GIF2JPG's "-j" option doesn't always produce a file in JFIF. If you have
to use a DOS converter, | recommend that you use the IJPEG Group's cjpeg program.
Otherwise, you should use WinJPEG's Batch Conversion feature, which performs the same
task as cjpeg except that only GIF and TARGA images are supported.




How to Register

If you use WinJPEG for more than 14 days, you are expected to register Win)JPEG. When you
register, you will receive the latest 286 and 386 versions of WinJPEG, a user manual, and a
collection of JPEG images (we will put as many as we can fit on 2 720k 3 1/2" floppies, on 1
1.44M 3 1/2" floppy, or on 4 360k 5 1/4" floppies). Also, the registered version does not
have the reminder-to-register screen at the start.

The registration fee is only $20. MA residents, add 5% sales tax to the registration fee. US
residents, add $3 for shipping and non-US residents, add $8 for shipping. If you want
WinJPEG e-mailed to your account instead of having it physically mailed to you, there is no
extra shipping charge.

Because of the lengthy time it takes to produce a new version and to distribute it to
registered users, updates are no longer free. Updates will cost $5. Those who registered in
October and November 1992 can obtain the next update for free. Shipping fees described
above apply to updates as well. Updates are available when you see a new shareware
version.

To register, complete the order form and send a check in US funds to:
Norman Yee

58 Chandler St.
Boston, MA 02116



Reporting Bugs

If you find a bug in WinJPEG, we would appreciate it if you would inform us of the bug
through one of our e-mail accounts:

Norman Yee
nyee@osiris.ee.tufts.edu

Ken Yee
kenyee@ksr.com

When you send us a bug report, include a description of the procedure for reproducing the
bug and a description of your system configuration(hardware and software).



License Agreement (applicable to registered users)

You are licensed to single-copy use of WinJPEG; this means that you can install your
registered version of WinJPEG simultaneously on one computer at work, one computer at
home, and one portable computer, if only one copy is in use by the registered individual at a
time. You may make copies of the registered WinJPEG disk as necessary for normal backup
purposes; you agree not to make any copies of the printed WinJPEG manual or the registered
version of WinJPEG for others.



Disclaimer

The authors of this program accept no responsibility for damages that are caused by this
program and make NO WARRANTY or representation, either express or implied, with respect
to this software. This software is provided "AS IS," and you, its user, assume the entire risk

when you use it.
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Win)JPEG Features

WInJPEG v.1.6 is a shareware image viewer with image processing and conversion
capabilities for Microsoft Windows 3.x. It has the following features:

- display JPEG, uncompressed TARGA, GIF 87a/89a, or Windows BMP images

- export an image to JPEG, uncompressed TARGA, GIF 87a, Windows BMP, or OS/2 BMP(8-bit
or 24-bit)

- display of JPEG images with 1-pass/2-pass quantization and Floyd-Steinberg dithering

- color balance: red, green, and blue adjustment

- hue, saturation, and brightness adjustment

- contrast enhancement

- image rotation, vertical/horizontal flip, and image resizing

- batch file conversion of GIF or TARGA files to JPEG

- slideshow: display selected files sequentially with a cycle option

- copy or paste images to or from the clipboard

- support for Windows 3.1 features like drag-drop and common dialogs

There are two versions of WinJPEG: a 386 version for 386's or better and a 286 one for 286's
or better. The shareware version is a 286 version. The 386 version can be obtained by
registering WinJPEG. See How to Register for more information.

Future versions of WinJPEG will have the following features:

- load/save TIFF and PCX files

- image cropping

- faster scrolling

- ability to delete file corresponding to currently displayed image
- more improvements



Corrupt GIF Images

There are some GIF files that display with no errors under other image viewers but when
they are viewed under WinJPEG, a "Premature End of GIF" error message is displayed .
These GIF files are probably corrupt; the GIF decoder routines in WinJPEG are stricter than
those used in other viewers. If you want to avoid seeing this error message when you load a
corrupt GIF, load it into WinJPEG, and overwrite the corrupt file by saving the displayed
image as a GIF.



Drag-drop Support

If you are using Windows 3.1, when you drag one or more files from File Manager to an open
WinJPEG and drop them there, WinJPEG will automatically enter the slideshow mode and
display those files in the order in which they are listed in File Manager. There is a delay,
which can be set in the Slideshow dialog box, between displayed pictures.






